Evaluation of latency with the evaluation feature

Post Reply
bb_85
Posts: 3
Joined: Sun Nov 27, 2016 6:34 pm

Evaluation of latency with the evaluation feature

Post by bb_85 » Sun Nov 27, 2016 7:04 pm

I can't start the evaluation query when I try to compute the latency. The evaluation feature shows results and plots, when computing throughput...However, every time I try to compute the latency, there is an error
de.uniol.inf.is.odysseus.planmanagement.executor.standardexecutor.StandardExecutor.addQuery:678
Could not add query '#PRETRANSFORM EvaluationPreTransformation

What I have tried so far to solve the problem:
- double checked if all necessary packages are installed / whether there are Odysseus updates
- tried to "activate" the computation of the latency by adding the command #METADATA latency
- tried to integrate the calculation of the latency in the "normal" query that has to be evaluated. I used the Grand Challenge 2015 as a hint how to do so and added ClacLatency at the last input operator before the sinks => the previously running query couldn't be started with the error "OdysseusScriptException - Encountered empty query"

Any help will be highly appreciated!

User avatar
Marco Grawunder
Posts: 272
Joined: Tue Jul 29, 2014 10:29 am
Location: Oldenburg, Germany
Contact:

Re: Evaluation of latency with the evaluation feature

Post by Marco Grawunder » Mon Nov 28, 2016 9:55 am

Hi,

the important part is after: "Could not add query '#PRETRANSFORM EvaluationPreTransformation"

could you please create a bug report. I think, we need more input ;-)

https://wiki.odysseus.offis.uni-oldenbu ... port+a+bug

Greetings,

Marco

bb_85
Posts: 3
Joined: Sun Nov 27, 2016 6:34 pm

Re: Evaluation of latency with the evaluation feature

Post by bb_85 » Mon Nov 28, 2016 8:54 pm

Bug report sent. Tried my best with explaining the issue...

Greetings

User avatar
Marco Grawunder
Posts: 272
Joined: Tue Jul 29, 2014 10:29 am
Location: Oldenburg, Germany
Contact:

Re: Evaluation of latency with the evaluation feature

Post by Marco Grawunder » Tue Nov 29, 2016 11:23 am

Ok, changed a little bit. Update will be available in a few hours.

bb_85
Posts: 3
Joined: Sun Nov 27, 2016 6:34 pm

Re: Evaluation of latency with the evaluation feature

Post by bb_85 » Wed Nov 30, 2016 12:23 pm

Hello,

I saw that there are updates for the evaluation feature and the latency package...Unfortunately after updating all available packages to the newest versions Odysseus won't start.
The error message is: "Login not possible since there are no login contributions"
Obviously I can't send a bug report now ...that's way I attached a screenshot from the console.
failed_login_odysseus.JPG
failed_login_odysseus.JPG (113.33 KiB) Viewed 302 times
Is there any way I can roll back the updates and at least start Odysseus?

User avatar
Marco Grawunder
Posts: 272
Joined: Tue Jul 29, 2014 10:29 am
Location: Oldenburg, Germany
Contact:

Re: Evaluation of latency with the evaluation feature

Post by Marco Grawunder » Wed Nov 30, 2016 12:42 pm

The error messages are pretty strange... I guess there are different versions of the same plugin ...

What happens, when you download a new version of Odysseus Studio and install the required features? The workspace and configuration will not be touched. A revert is currently not supported by the eclipse patform.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest