Odysseus

This is the official support forum for Odysseus

Unresolved OSGI Requirements

stefan
Posts: 85
Joined: Tue Jul 12, 2016 1:03 pm

Unresolved OSGI Requirements

Postby stefan » Thu Dec 08, 2016 8:54 pm

Hello,

since my pull yesterday there is a unresolved requirement: Require-Bundle: com.google.guava; bundle-version="18.0.0"

I checked the "Run configurations" for Odysseus and validated the plug-ins. The com.google.guava is activated, but only version 15. Version 18 is not available here.

Here one of the corresponding exceptions:

Code: Select all

!ENTRY de.uniol.inf.is.odysseus.parser.cql 4 0 2016-12-08 19:44:49.408
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: de.uniol.inf.is.odysseus.parser.cql [31]
  Unresolved requirement: Import-Package: de.uniol.inf.is.odysseus.server.intervalapproach; resolution:="optional"
    -> Export-Package: de.uniol.inf.is.odysseus.server.intervalapproach; bundle-symbolic-name="de.uniol.inf.is.odysseus.server.intervalapproach"; bundle-version="1.0.0.qualifier"; version="0.0.0"
       de.uniol.inf.is.odysseus.server.intervalapproach [89]
         Unresolved requirement: Require-Bundle: com.google.guava; bundle-version="18.0.0"
  Unresolved requirement: Require-Bundle: de.uniol.inf.is.odysseus.server.intervalapproach
    -> Bundle-SymbolicName: de.uniol.inf.is.odysseus.server.intervalapproach; bundle-version="1.0.0.qualifier"

   at org.eclipse.osgi.container.Module.start(Module.java:434)
   at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
   at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
   at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
   at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
   at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
   at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
   at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)


How can I solve this issue?

greetings,
Stefan

User avatar
Marco Grawunder
Posts: 264
Joined: Tue Jul 29, 2014 10:29 am
Location: Oldenburg, Germany
Contact:

Re: Unresolved OSGI Requirements

Postby Marco Grawunder » Thu Dec 08, 2016 9:08 pm

Hi Stefan,

please try to find, if there are any new projects available (Import ... Existings Projects)

Greetings,

Marco

stefan
Posts: 85
Joined: Tue Jul 12, 2016 1:03 pm

Re: Unresolved OSGI Requirements

Postby stefan » Fri Dec 09, 2016 12:19 pm

Thanks, that was the problem.


phpbb 3.1 style demo

Return to “Installation/Configuration”

Who is online

Users browsing this forum: No registered users and 1 guest