org.osgi.framework.BundleException: Could not find bundle: unknown

tbrandt
Posts: 4
Joined: Fri Dec 16, 2016 5:55 pm

Re: org.osgi.framework.BundleException: Could not find bundle: unknown

Post by tbrandt » Tue Feb 21, 2017 5:20 pm

Regarding the NoClassDefFoundError: If you checkout the source code from the git repository and import it in eclipse with "Import" -> "Existing project into workspace" it should not be necessary to add any library (except you are on Linux and have to add JavaFX, but that's probably not the case for you).

When creating another project in that same workspace in eclipse, you should be able to add the client library project to the build path and use it without exporting any jar. (But exporting a jar is of course another possibility). The following image shows what I mean:
Selection_002.png
Selection_002.png (100.58 KiB) Viewed 321 times

Jadine
Posts: 7
Joined: Tue Feb 21, 2017 2:12 pm

Re: org.osgi.framework.BundleException: Could not find bundle: unknown

Post by Jadine » Tue Feb 21, 2017 5:31 pm

Hi,
okay it seems to be a port problem.
This is our server message:

Code: Select all

Feb 21, 2017 4:15:14 PM org.restlet.engine.connector.NetServerHelper start
INFO: Starting the internal [HTTP/1.1] server on port 9681
157  INFO  RestService  - Restservice published at 9681 - de.uniol.inf.is.odysseus.rest.service.RestService.start(RestService.java:52) 
Could we change the port of the server or the port of the client?

tbrandt
Posts: 4
Joined: Fri Dec 16, 2016 5:55 pm

Re: org.osgi.framework.BundleException: Could not find bundle: unknown

Post by tbrandt » Tue Feb 21, 2017 5:47 pm

If this really is the problem, the solution could be fairly simple. Add the port to the IP in the client code:

Code: Select all

String loginIp = "127.0.0.1:9681";

Jadine
Posts: 7
Joined: Tue Feb 21, 2017 2:12 pm

Re: org.osgi.framework.BundleException: Could not find bundle: unknown

Post by Jadine » Tue Feb 21, 2017 5:56 pm

Thank you. That did the trick.

User avatar
Marco Grawunder
Posts: 272
Joined: Tue Jul 29, 2014 10:29 am
Location: Oldenburg, Germany
Contact:

Re: org.osgi.framework.BundleException: Could not find bundle: unknown

Post by Marco Grawunder » Tue Feb 21, 2017 6:17 pm

Fine :-)

Just a remark. The port should be fixed and will be increased only if the port is blocked (e.g. by another Odysseus instance). So I guess, when you shutdown Eclipse and start again, the port will be the regular one again (if you did not have other allications that use that port).

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest