Cannot complete the install because of a conflicting dependency

Post Reply
User avatar
Marco Grawunder
Posts: 272
Joined: Tue Jul 29, 2014 10:29 am
Location: Oldenburg, Germany
Contact:

Cannot complete the install because of a conflicting dependency

Post by Marco Grawunder » Mon Dec 07, 2015 4:36 pm

We updated our RCP base plattform to support Java in version 8, its now Eclipse Mars (4.5).

If you use the old product and try an update, you will see something like:

Code: Select all

Cannot complete the install because of a conflicting dependency.
  Software being installed: Monolithic 1.0.0.26692-3--cCmyaW7EH9px1mkDwGfB5MV (de.uniol.inf.is.odysseus.monolithic.feature.feature.group 1.0.0.26692-3--cCmyaW7EH9px1mkDwGfB5MV)
  Software currently installed: Odysseus Client Platform 1.0.0 (de.uniol.inf.is.odysseus.product.studio 1.0.0)
  Only one of the following can be installed at once: 
    Expression Language 3.4.300.v20110228 (org.eclipse.core.expressions 3.4.300.v20110228)
    Expression Language 3.5.0.v20150421-2214 (org.eclipse.core.expressions 3.5.0.v20150421-2214)
In this case you have to download a new version from the download section and install the required plugins manually again.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests